Does Sticky Sidebars work with my theme?

With Content Aware Sidebars, you can now create sticky WordPress sidebars and widget areas. No jQuery and no bloat that will slow down your site.

The feature already supports many WordPress themes used by millions of people combined, but due to the variety of themes and the differences in the way they are coded, some are not yet ready or compatible with 1-click sticky WordPress sidebars.

 

WordPress Themes tested with Sticky Sidebars

Sticky sidebars have been officially tested to fully work out-of-the-box in the following themes:

  • Activello
  • Allium
  • Anther
  • Astra
  • Astrid
  • Avada
  • Cenote
  • ColorMag
  • Corporate Key
  • Customify
  • Customizr
  • Dara
  • Donovan
  • EmpowerWP
  • Envo eCommerce
  • Escapade
  • Flash
  • Flatsome
  • GeneratePress
  • Gutenbiz
  • Hestia
  • Hueman
  • i-max
  • Iconic One
  • Kale
  • Lalita
  • Lyrical
  • Merlin
  • Mesmerize
  • NewsCard
  • NewShop eCommerce
  • NewStore
  • OceanWP
  • One Page Express
  • Orfeo
  • Page Builder Framework
  • Porto
  • Poseidon
  • Primer
  • Scribbles
  • Shop Isle
  • Sparkling
  • Stout
  • Sydney
  • Themedd
  • Total
  • Twenty Fourteen
  • Twenty Fifteen
  • Twenty Sixteen
  • Twenty Seventeen
  • Uptown Style
  • Varuna
  • Velux
  • Virtue
  • WP Bootstrap Starter
  • Writee
  • Zakra

 

Sticky Sidebars partial theme support

The following themes are compatible with sticky sidebars only when inserting via infusion or shortcode:

  • Consulting
  • Genesis
  • Highlight
  • Illdy
  • Spacious

 

The following themes are compatible with sticky sidebars only when replacing theme sidebars:

  • Airi
  • Ascension
  • Ashe
  • Bard
  • Nisarg

     

    Themes incompatible with Sticky Sidebars

    • Bizberg
    • Colibri
    • Futurio
    • Head Blog
    • Materialis
    • Neve
    • Onepress
    • Phlox
    • Responsive
    • Rife Free
    • Shapely
    • Storefront
    • The7
    • Vantage

     

    Good to know: If your theme is not listed above, it does not necessarily mean that it is not supported. Please click here if you have any questions or feedback.

    .

    Was this article helpful to you?